Star Wars Squadrons

(Like and sharing game for your friends)

GAME NAME
Star Wars Squadrons
LANGUAGE
Multi
RELEASE
2020
GENRE
Simulation

Download

———————————-

CUSA15089 – EUR

Link Download

Note: Game for PS4 – not use PS3

Thank @DUPLEX

CUSA15089 – EUR

Note : Link Zippy only use with Jdownload2

Game + Update 1.03 : LetsZippy1File

Update 1.03 (Fix 5.05) : Download

Password: downloadgameps3.com

Audio  : English, German, French and Spanish.

Subtitle : English, German, Russian, Italian, French, Polish and Spanish.

Guide DownloadTool Download )

———————————-

CUSA15080 – USA

Link Download

Note: Game for PS4 – not use PS3

Thank @Seanp2500

CUSA15080 – USA

Note : Link Zippy only use with Jdownload2

Game : LetsZippy1File

Update 1.03 : LetsZippy1File

Update 1.03 (Fix 5.05/6.72/7.02) : Download

Password: downloadgameps3.com

Voice : English, French (France), Spanish

Screen Languages : Chinese (Simplified), Chinese (Traditional), English, French (France), Japanese, Korean, Portuguese (Brazil), Spanish, Spanish (Mexico)

Guide DownloadTool Download )

Link Mirror

Note: Game for PS4 – not use PS3

Thank @Seanp2500 & AVB

CUSA15080 – USA

Game + Update 1.03 : Zippy

Update 1.03 (Fix 5.05/6.72/7.02) : Download

Voice : English, French (France), Spanish

Screen Languages : Chinese (Simplified), Chinese (Traditional), English, French (France), Japanese, Korean, Portuguese (Brazil), Spanish, Spanish (Mexico)

Guide DownloadTool Download )

Master the art of starfighter combat in the authentic piloting experience STAR WARS™: Squadrons. Buckle up and feel the adrenaline of first-person multiplayer space dogfights alongside your squadron.

Take control of starfighters from both the New Republic and Imperial fleets such as the X-wing and TIE fighter. Customize loadouts and cosmetics, divert power between weapons, shields, and engines, while immersing yourself in the cockpit. In addition, players will have the option to play the entirety of the game in virtual reality on PlayStation®VR!

Learn what it means to be a pilot in a thrilling STAR WARS™ single-player story set after the events of Return of the Jedi and seen from alternating perspectives between two factions. The New Republic fights for freedom. The Empire demands order. We need you to join the galaxy’s finest.

5 1 vote
Article Rating
guest
62 Comments
Newest
Oldest Most Voted
Inline Feedbacks
View all comments
Face Ltd

I did not wait for the backport to the European release from Duplex Star Wars Squadron (CUSA15089), so I made it with handles by myself. Backport 5.05 with patch 1.03:
https://yadi.sk/d/LAkL2buUtqVSGw

AnjunaBaba

Works on 6.72! Thanks a lot!

l3tsplayPS4_0n_672

Thanks @Seanp2500 @Admin-psp

fedor1280

Cusa15089-EUR backport?PLEASE

Samido Samad

in eur version in not working in 7.02 pleez give a solution

l3tsplayPS4_0n_672

fix for duplex release please TIA.

ricky

my apologies for the question .. but how to spoof à firmware ?

seanp2500

depends on your firmware. I like to use 6.72 and psphive menu by leeful. In this webhost I choose hen b after exploit and then spoof is simply a tab or option and I select 8.00 I hope this helps. It’s working rather well for me. See here:

ricky

sorry , i’m in 5.05. it’s the same process ? with witch webhost ? thx a lot.

ricky

i found the process on 5.05. thx again for the help.

Its me Mario

Hey pal, I’m on 5.05 too. Did you managed to install and play? could you explain how? Thanks

ricky

you need to go on the features of your hen. search “spoof ” the spoof appear on 5.05 ( your actual fw.) on the bottom off your screen. twist the number up to 7.55. and tada, its works.
thx a lot again to seanp2500 😉
ps: before i forget : anybody can tell me if the news backups , works in that way on 5.05?or any works only 7.55 cfw ?
if the boss of this website read this , it is possible to mention it on the post of the releases ?
thx for the job et the patience .

Last edited 1 month ago by ricky
robe36

BTW if you use Al Azif exploit, he mentioned the other day that his automatically spoofs to 9.01fw for 5.05…one of the recent posts going down his twitter page

Murielinyo

Cusa15089-EUR backport?

CyB1K

[CUSA15080] Star Wars Squadrons Update 1.03 Already Backported

U3RhciBXYXJzIFNxdWFkcm9ucyBVcGRhdGUgMS4wMyBGdWxseSBCYWNrcG9ydGVkCgpodHRwczovLzFmaWNoaWVyLmNvbS8/M3FiOTV1M2xqMTRxczhveTRpOWsKCkluc3RhbGwgVGhlIEJhc2UgR2FtZSAiU1RBUiBXQVJTIC0gU3F1YWRyb25zIFtDVVNBMTUwODBdIFt2MDEuMDBdLnBrZyIgVGhlbiBJbnN0YWxsIFRoaXMgVXBkYXRlIChObyBGaXhlcyBSZXF1aXJlZCkKCkNyZWRpdHMgdG8gU2VhbnAyNTAwIGZvciB0aGUgZHVtcCEKCk5vdGVzOiA1LjA1IC8gNi43MiAvIDcuMDIgQmFja3BvcnQhIE5lZWRzIGZpcm13YXJlIHNwb29mIHRvIGluc3RhbGwgYW5kIHBsYXkgOikKCkVuam95CgpCeSBDeUIxSw==

Credits to Seanp2500 for the dump!
Notes: 5.05 / 6.72 / 7.02 Backport! Needs firmware spoof to install and play 🙂

Lustral

Is a 5.05 for the DUPLEX-CUSA15089–EUR also possible CyB1K?

Chucknoris40

Game Fix 6.72 Please

seanp2500

Star Wars Squadrons Update 1.03 Fully Backported

https://1fichier.com/?3qb95u3lj14qs8oy4i9k

Install The Base Game “STAR WARS – Squadrons [CUSA15080] [v01.00].pkg” Then Install This Update (No Fixes Required)

Credits to Seanp2500 for the dump!

Notes: 5.05 / 6.72 / 7.02 Backport! Needs firmware spoof to install and play 🙂

Enjoy

By CyB1K

Chucknoris40

Star wars CUSA15089 – EUR have you fBackport?

C0br4

You’re my hero

seanp2500

no CyB1K is one who saved you. But we need to support him. Please donate to those who help us. You can donate to CyB1K here:

https://www.paypal.com/paypalme/CyB1K

pajman

dont work on 7.02 need backport

Shinji

Hi, I have problem to install this game on my ps4 7.02 (4TB internal hdd) always get error CE-37732-2

Chucknoris40

Author Thanks, for Euro Version

c0br4

EUR version also not working yet on 6.72 due to missing backport I presume?

Last edited 1 month ago by c0br4
l3tsplayPS4_0n_672

Duplex release please. TIA

NELLOFOX

version CUSA15089 dlc?

sadako

hello. i have an error when i try to extract the archives. does anyone know why?

nuriel

My most awaited game after TLOU2. Thanks!! waiting for the 6.72 fix

Jay

This will be more difficult than others because of EA patch requiring off sets. Could be months or whenever someone knowledgeable about it decides to tackle it.

Jay

Why isn’t my post approved? It’s very important information about backporting.

official

7.50 – > 6.72 / 5.05 Backporting failed…

Jay

I think it needs additional patches cause it’s an EA game.

CyB1K

It needs a patch on save like bayonetta and vanquish from what i heard, along other things. But im going to bed, my 2 day offs were spent 18h on ida each lol

Last edited 1 month ago by CyB1K
Jay

You also can’t backport EA games without additional offset. So this one will be difficult to backport.

seanp2500

It happened. Deal with it.

dst

ah buggar this is for 7.50

seanp2500
Chucknoris40

Please Euro Version with Germany, thanks

ADILOV

nba 2K21- FIFA21 PLEASE ADMIN AND THANKS

Arcajulio

I LOVE YOU!!
EU AMO VOCÊS!!
Esse era o jogo que eu mais queria jogar no PS4
Muuuuuuitooooo obrigado!
My eternal Thanksssss!!!

Eli

and also mortal kombat 11 patch v1.18

Eli

Thank you so much. just do me a favour and upload marvels avengers with back port and spider man miles morales back port please

seanp2500

wtf is this a short order kitchen?

shacko

thanks for the laugh

c0br4

basically yes. The mods even write on this site we should make requests in the comments section.

seanp2500

im just joking about it

c0br4

Sorry I’m german, my englisch ist kwite bäd. whats a joke supposed to be again?

c0br4

I demand that you upload SkyrimVR 1.04 patch. No excuses!

shacko

here you go

Annotation 2021-03-16 182330.png
Jay

Does it need a backport for 6.72.

seanp2500

yes i am sorry i tried and failed

Jay

I think EA fix requires additional EA patch to base game.

JRPG FAN

Hi grabman, Waiting for ASHEN. NEW JB IS OUT! You promise upload ASHEN. REMEMBER THAT! THANKS MAN!

c0br4

Did he do the pinky swear though?

seanp2500

of course i kept my fingers crossed thus making the agreement null and void this yom kippur…

i said too much…

c0br4

NIce loophole. I’ll try this with my girlfriend if that one subject pops up again.

Last edited 1 month ago by c0br4
seanp2500

we need 8.1 kex but pkg is secured

Tags: